aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJesse Barnes <jbarnes@virtuousgeek.org>2009-01-07 11:47:52 -0800
committerJesse Barnes <jbarnes@virtuousgeek.org>2009-01-07 11:47:52 -0800
commitbadc63464cbd64606c6dff9ea561a787d072fd5f (patch)
tree66d7fe7ca2d94052f156f7cf27ff25ef243b53ec /configure.ac
parentca37077fb78b69a00500827f1db12b70affa1514 (diff)
libdrm: add autoconf check for clock_gettime
Should be more portable this way.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ccc58ef7..11d238cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,13 @@ AC_DEFUN([LIBDRM_CC_TRY_FLAG], [
AC_MSG_RESULT([$libdrm_cc_flag])
])
+dnl We use clock_gettime to check for timeouts in drmWaitVBlank
+
+AC_CHECK_FUNCS([clock_gettime], [CLOCK_LIB=],
+ [AC_CHECK_LIB([rt], [clock_gettime], [CLOCK_LIB=-lrt],
+ [AC_MSG_ERROR([Couldn't find clock_gettime])])])
+AC_SUBST([CLOCK_LIB])
+
dnl Use lots of warning flags with with gcc and compatible compilers
dnl Note: if you change the following variable, the cache is automatically