aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2009-04-06 17:13:01 -0400
committerKristian Høgsberg <krh@redhat.com>2009-04-06 17:13:01 -0400
commite9d6116e5bd30639d6333ef95462fe300f47ccd5 (patch)
treef704c598394685cffea66bf6bdccf88a1b6ea96e /configure.ac
parent51d6346f9f3c425f49e57d185530c6bcaeb94f5e (diff)
Use libudev in test case to only run gem tests for intel devices.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8be1e2a4..2e32c840 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,6 +131,13 @@ if test "x$HAVE_CAIRO" = xyes; then
fi
AM_CONDITIONAL(HAVE_CAIRO, [test "x$HAVE_CAIRO" = xyes])
+# For enumerating devices in test case
+PKG_CHECK_MODULES(LIBUDEV, libudev, [HAVE_LIBUDEV=yes], [HAVE_LIBUDEV=no])
+if test "x$HAVE_LIBUDEV" = xyes; then
+ AC_DEFINE(HAVE_LIBUDEV, 1, [Have libudev support])
+fi
+AM_CONDITIONAL(HAVE_LIBUDEV, [test "x$HAVE_LIBUDEV" = xyes])
+
AC_SUBST(WARN_CFLAGS)
AC_OUTPUT([