aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-05-12 13:55:34 -0400
committerKristian Høgsberg <krh@bitplanet.net>2010-05-12 13:55:54 -0400
commit52a3e9df629952e58bd019b8cd4cda1dd254a543 (patch)
tree1f36038ebdff8d5916073f4f0244532ef4a93d20 /tests/Makefile.am
parent62731b84114e5dd3310b465921955db14278c256 (diff)
Only build tests in make check
Currently, all the tests for libdrm are built during 'make all', even if you do not wish to run tests. Attached is a patch, based on version 2.4.15, to make the tests build in 'make check'.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5d240a05..ebf4853a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,7 +6,7 @@ AM_CPPFLAGS = \
LDADD = $(top_builddir)/libdrm.la
-noinst_PROGRAMS = \
+check_PROGRAMS = \
dristat \
drmstat
@@ -21,7 +21,7 @@ endif
if HAVE_LIBUDEV
-EXTRA_LTLIBRARIES = libdrmtest.la
+check_LTLIBRARIES = libdrmtest.la
libdrmtest_la_SOURCES = \
drmtest.c \
@@ -63,8 +63,6 @@ TESTS += \
$(NULL)
endif
-EXTRA_PROGRAMS = $(TESTS)
+check_PROGRAMS += $(TESTS)
endif
-
-CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES)