aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2007-07-19 04:59:59 -0700
committerEric Anholt <eric@anholt.net>2007-07-19 04:59:59 -0700
commitd7cf298e540c631795868c52b044c7249bf45902 (patch)
tree4b810f37f48351f512080c56039b9e4cc6f7634a /tests/Makefile.am
parent51de9ec5e38426b13a1da0f78f3a0894dcb3e495 (diff)
Add some trivial regression tests, one of which fails.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 00000000..815dae57
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,24 @@
+AM_CFLAGS = \
+ -I $(top_srcdir)/shared-core
+
+noinst_PROGRAMS = \
+ dristat \
+ drmstat
+
+EXTRA_LTLIBRARIES = libdrmtest.la
+libdrmtest_la_SOURCES = \
+ drmtest.c \
+ drmtest.h
+libdrmtest_la_LIBADD = \
+ $(top_builddir)/libdrm/libdrm.la
+
+LDADD = libdrmtest.la
+
+TESTS = openclose \
+ getversion \
+ getclient
+
+XFAIL_TESTS = getclient
+
+EXTRA_PROGRAMS = $(TESTS)
+CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES) \ No newline at end of file