aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e66d1c82..123c5478 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,19 +6,22 @@ noinst_PROGRAMS = \
dristat \
drmstat
+SUBDIRS = \
+ modeprint \
+ modetest
+
+if HAVE_LIBUDEV
+
EXTRA_LTLIBRARIES = libdrmtest.la
libdrmtest_la_SOURCES = \
drmtest.c \
drmtest.h
libdrmtest_la_LIBADD = \
- $(top_builddir)/libdrm/libdrm.la
+ $(top_builddir)/libdrm/libdrm.la \
+ $(LIBUDEV_LIBS)
LDADD = libdrmtest.la
-SUBDIRS = \
- modeprint \
- modetest
-
TESTS = auth \
openclose \
getversion \
@@ -33,5 +36,8 @@ TESTS = auth \
gem_mmap
EXTRA_PROGRAMS = $(TESTS)
+
+endif
+
CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES)