summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olvaffe@gmail.com>2009-12-23 11:18:00 +0800
committerBrian Paul <brianp@vmware.com>2010-01-05 08:08:34 -0700
commite5d351dcfde58777162552cf5cd2a9cd8299f4cd (patch)
treec17b93c6616e31169cd430cf59775ee6b1c98ed0 /configure.ac
parent976c858acc36b5ec1bf03c24b10e8bae81c2a21f (diff)
Add es state tracker to autoconf.
mesa/es is needed in SRC_DIRS to build es state tracker. Signed-off-by: Chia-I Wu <olvaffe@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 13 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index cc588d5fab..2984ee24a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1154,14 +1154,22 @@ yes)
test -d "$srcdir/src/gallium/state_trackers/$tracker" || \
AC_MSG_ERROR([state tracker '$tracker' doesn't exist])
- if test "$tracker" = egl && test "x$enable_egl" != xyes; then
- AC_MSG_ERROR([cannot build egl state tracker without EGL library])
- fi
- if test "$tracker" = xorg; then
+ case "$tracker" in
+ egl)
+ if test "x$enable_egl" != xyes; then
+ AC_MSG_ERROR([cannot build egl state tracker without EGL library])
+ fi
+ ;;
+ xorg)
PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
HAVE_XEXTPROTO_71="yes"; DEFINES="$DEFINES -DHAVE_XEXTPROTO_71",
HAVE_XEXTPROTO_71="no")
- fi
+ ;;
+ es)
+ # mesa/es is required to build es state tracker
+ SRC_DIRS="mesa/es $SRC_DIRS"
+ ;;
+ esac
done
GALLIUM_STATE_TRACKERS_DIRS="$state_trackers"
;;