aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 16 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af55c1f..5019c8d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,20 @@ set(CMAKE_CXX_STANDARD 17)
# Initialize the SDK
pico_sdk_init()
-add_executable(morningtown morningtown.c)
-target_link_libraries(morningtown pico_stdlib hardware_rtc)
+add_executable(morningtown morningtown.c ntp_client.c)
+
+# For verbose debugging, uncomment this line and see ntp_client.h
+#pico_enable_stdio_usb(morningtown ENABLED)
+
+target_link_libraries(morningtown
+ pico_stdlib
+ hardware_rtc
+ pico_cyw43_arch_lwip_threadsafe_background)
+
pico_add_extra_outputs(morningtown)
+
+target_compile_definitions(morningtown PRIVATE
+ WIFI_SSID=\"${WIFI_SSID}\"
+ WIFI_PASSWORD=\"${WIFI_PASSWORD}\")
+
+target_include_directories(morningtown PRIVATE ${CMAKE_CURRENT_LIST_DIR})