aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2009-07-20 00:12:10 +0100
committerThomas White <taw@bitwiz.org.uk>2009-07-20 00:12:10 +0100
commitd0edf1adfe67bc11af7aee849004a1acafd0ed4a (patch)
tree54eaeac3874d3e46a2c650a70446840e435fe874 /configure.ac
parent1f734762998ff92dff6173e877ece014a288b7b5 (diff)
Some fixesalsa
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a1898a1..027e451 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,12 +41,13 @@ else
fi
AC_MSG_CHECKING([for ALSA])
-if $PKG_CONFIG sdl ; then
+if $PKG_CONFIG alsa ; then
ALSA_CFLAGS=`$PKG_CONFIG --cflags alsa`
ALSA_LIBS=`$PKG_CONFIG --libs alsa`
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([not found])
+ AC_MSG_ERROR([*** ALSA not found. Do you have 'libasound-dev' or similar installed?])
fi
CFLAGS="$CFLAGS $GTK_CFLAGS $LIBSDL_CFLAGS $ALSA_CFLAGS"