aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-01-12 11:22:08 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-01-12 11:22:08 +0000
commitb9ca7b1ef5cd1f96ae6e28ae78d12c1e3258c23f (patch)
tree1203adec5f70af1ddd49868528d8d3a5b9004329 /Makefile.am
Initial import of Sylpheed (GTK2 version).
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@1 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..b2ba8f4d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,27 @@
+SUBDIRS = ac po intl src manual faq
+
+EXTRA_DIST = config.rpath \
+ ChangeLog.jp \
+ INSTALL.jp \
+ README.jp \
+ TODO.jp \
+ sylpheed.desktop \
+ sylpheed.spec \
+ sylpheed.spec.in \
+ sylpheed.png \
+ sylpheed-128x128.png \
+ sylpheed-64x64.png \
+ autogen.sh
+
+BZIP2_ENV =
+
+release: distdir
+ -chmod -R a+r $(distdir)
+ GZIP=$(GZIP_ENV) $(TAR) chozf $(distdir).tar.gz $(distdir)
+ rm -f $(distdir)/sylpheed.spec
+ sed '/^Source:/s/\.tar\.gz$$/\.tar\.bz2/' sylpheed.spec \
+ > $(distdir)/sylpheed.spec
+ BZIP2=$(BZIP2_ENV) $(TAR) --bzip2 -chof $(distdir).tar.bz2 $(distdir)
+ -rm -rf $(distdir)
+
+ACLOCAL_AMFLAGS = -I m4