aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2006-08-07 01:37:04 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2006-08-07 01:37:04 +0000
commit2d2c86cbd9bbd1fc44ff338ed89ebae535c359a5 (patch)
treea9db0255b4a49688896ebd538f582f0d4aa90bbd /configure.in
parent5f8638ac50b29776fadd8f416e6aa5e6f76a112b (diff)
use onig-config in configure.in.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@1118 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 11 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index c046a397..82a82b90 100644
--- a/configure.in
+++ b/configure.in
@@ -282,21 +282,17 @@ AC_ARG_ENABLE(oniguruma,
AC_MSG_CHECKING([whether to use Oniguruma])
if test "$ac_cv_enable_oniguruma" = yes; then
AC_MSG_RESULT(yes)
- AC_CHECK_HEADERS(oniguruma.h onigposix.h,
- [ AC_DEFINE(USE_ONIGURUMA, 1, Define if you want to use Oniguruma.) ],
- [ ac_cv_enable_oniguruma=no ])
-
- if test "$ac_cv_enable_oniguruma" = yes; then
- AC_CHECK_LIB(onig, onig_new,
- [ ac_cv_enable_oniguruma=yes ],
- [ ac_cv_enable_oniguruma=no ])
- fi
-
- AC_MSG_CHECKING([whether oniguruma is available])
- AC_MSG_RESULT($ac_cv_enable_oniguruma)
-
- if test "$ac_cv_enable_oniguruma" = yes; then
- LIBS="$LIBS -lonig"
+ AC_MSG_CHECKING([whether Oniguruma is available])
+ dnl AC_CHECK_PROG(ONIG_CONFIG, onig-config, onig-config)
+ ONIG_CONFIG=onig-config
+ if $ONIG_CONFIG --version; then
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS `$ONIG_CONFIG --cflags`"
+ LIBS="$LIBS `$ONIG_CONFIG --libs`"
+ AC_DEFINE(USE_ONIGURUMA, 1, Define if you want to use Oniguruma.)
+ else
+ AC_MSG_RESULT(no)
+ ac_cv_enable_oniguruma=no
fi
else
AC_MSG_RESULT(no)