aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2010-12-09 02:44:22 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2010-12-09 02:44:22 +0000
commita29ad00ed3ce3d185b152eacb913442150ba9f32 (patch)
tree7b35f1caec96a5b80ed0f29c89639e0c46d77375 /configure.in
parentfc06fff3379a6fa47d8acd2f8aa39719fd79b3c7 (diff)
enable updatecheckplugin only if updatecheck is enabled.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@2744 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e51f410c..45eb9427 100644
--- a/configure.in
+++ b/configure.in
@@ -402,14 +402,14 @@ AC_ARG_ENABLE(updatecheck,
[ac_cv_enable_updatecheck=$enableval], [ac_cv_enable_updatecheck=yes])
if test x"$ac_cv_enable_updatecheck" = xyes ; then
AC_DEFINE(USE_UPDATE_CHECK, 1, Define if you want update check feature.)
-fi
-dnl for update check feature
-AC_ARG_ENABLE(updatecheckplugin,
+ dnl for update check feature (requires update check enabled)
+ AC_ARG_ENABLE(updatecheckplugin,
[ --disable-updatecheckplugin Disable update check plugin feature],
[ac_cv_enable_updatecheckplugin=$enableval], [ac_cv_enable_updatecheckplugin=yes])
-if test x"$ac_cv_enable_updatecheckplugin" = xyes ; then
+ if test x"$ac_cv_enable_updatecheckplugin" = xyes ; then
AC_DEFINE(USE_UPDATE_CHECK_PLUGIN, 1, Define if you want update check plugin feature.)
+ fi
fi
dnl Check for d_type member in struct dirent