aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2010-11-02 11:56:07 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2010-11-02 11:56:07 +0000
commitbddb4823743f012b5905f553cbe4f3c6575361b4 (patch)
tree6d33787943262104fd4df86aa13e1c16b1b7babd /configure.in
parent68379640644a6ba3870e2e230687d6a19946e008 (diff)
merged plug-in update check and automatic update patch.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@2707 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 18eabd79..57b9dc3e 100644
--- a/configure.in
+++ b/configure.in
@@ -404,6 +404,14 @@ if test x"$ac_cv_enable_updatecheck" = xyes ; then
AC_DEFINE(USE_UPDATE_CHECK, 1, Define if you want update check feature.)
fi
+dnl for update check feature
+AC_ARG_ENABLE(updatecheckplugin,
+ [ --disable-updatecheckplugin Disable update check plugin feature],
+ [ac_cv_enable_updatecheckplugin=$enableval], [ac_cv_enable_updatecheckplugin=yes])
+if test x"$ac_cv_enable_updatecheckplugin" = xyes ; then
+ AC_DEFINE(USE_UPDATE_CHECK_PLUGIN, 1, Define if you want update check plugin feature.)
+fi
+
dnl Check for d_type member in struct dirent
AC_MSG_CHECKING([whether struct dirent has d_type member])
AC_CACHE_VAL(ac_cv_dirent_d_type,[