aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-03-01 16:19:54 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-03-01 16:19:54 +0000
commitca379fae66a6a1d0e23e2655d3363bec181d0c31 (patch)
treec5cfd20a8e66182724386968130ef24c60ccda39 /configure.in
parent1ae3f0de4c075b75f8899c76a59073c36daa1058 (diff)
fixed LDAP compilation.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@138 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index a6a797bb..0704c6d1 100644
--- a/configure.in
+++ b/configure.in
@@ -60,10 +60,6 @@ case "$target" in
esac
dnl Checks for libraries.
-PKG_CHECK_MODULES(GTK, \
- [ glib-2.0 gthread-2.0 gdk-pixbuf-2.0 gtk+-2.0 ], ,
- [ AC_MSG_ERROR(Test for GTK+-2.0 failed. See the file 'INSTALL' for help.) ])
-
AM_PATH_GLIB_2_0(2.4.0,, AC_MSG_ERROR(Test for GLib failed. See the 'INSTALL' for help.))
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
@@ -183,8 +179,8 @@ if test "$ac_cv_enable_ldap" = yes; then
AC_MSG_RESULT($ac_cv_enable_ldap)
if test "$ac_cv_enable_ldap" = yes; then
- CFLAGS="$CFLAGS `$GLIB_CONFIG --cflags gthread`"
- LDAP_LIBS="$LDAP_LIBS -lldap `$GLIB_CONFIG --libs gthread`"
+ CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gthread-2.0`"
+ LDAP_LIBS="$LDAP_LIBS -lldap `$PKG_CONFIG --libs gthread-2.0`"
AC_DEFINE(USE_LDAP, 1, Define if you want LDAP support in addressbook.)
AC_SUBST(LDAP_LIBS)
fi
@@ -231,9 +227,9 @@ dnl [use_threads=$enableval], [use_threads=no])
AC_MSG_CHECKING([whether to use threads])
if test x"$use_threads" = xyes ; then
AC_MSG_RESULT(yes)
- if test ! -z `$GLIB_CONFIG --help 2>&1 |grep 'gthread'` ; then
- CFLAGS="$CFLAGS `$GLIB_CONFIG --cflags gthread`"
- LIBS="$LIBS `$GLIB_CONFIG --libs gthread`"
+ if test ! -z `$PKG_CONFIG --help 2>&1 |grep 'gthread-2.0'` ; then
+ CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gthread-2.0`"
+ LIBS="$LIBS `$PKG_CONFIG --libs gthread-2.0`"
AC_DEFINE(USE_THREADS, 1, Whether to use multithread or not)
else
AC_MSG_ERROR([Sylpheed requires GThread from GLib to use threading.])