aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2009-12-28 05:00:53 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2009-12-28 05:00:53 +0000
commitf4ab0f022c847485d347d1ce8cd2ffcde3497f56 (patch)
treea09345c7580cdeb102f97a6510a01e3b46132081 /configure.in
parentf0ded112875ffa7337d442bd05abdd97170d8dc1 (diff)
added configure option '--disable-updatecheck' which disables the update check feature.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@2407 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5aa28dbc..3cfadb93 100644
--- a/configure.in
+++ b/configure.in
@@ -385,6 +385,14 @@ else
AC_MSG_RESULT(no)
fi
+dnl for update check feature
+AC_ARG_ENABLE(updatecheck,
+ [ --disable-updatecheck Disable update check feature],
+ [ac_cv_enable_updatecheck=$enableval], [ac_cv_enable_updatecheck=yes])
+if test x"$ac_cv_enable_updatecheck" = xyes ; then
+ AC_DEFINE(USE_UPDATE_CHECK, 1, Define if you want update check feature.)
+fi
+
dnl Check for d_type member in struct dirent
AC_MSG_CHECKING([whether struct dirent has d_type member])
AC_CACHE_VAL(ac_cv_dirent_d_type,[