aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2011-01-24 08:36:12 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2011-01-24 08:36:12 +0000
commit38f46204d02b2aaf3e61b480c13ab92bcedfde87 (patch)
treee60d9807934bf9d9dc2fbbe9ddfe7aae8fa65ead /src/Makefile.am
parentc405270db9c1de428a99c5525ab7c3c7f203ea7b (diff)
added marshaller for plug-in library. made 3.1.0rc.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@2822 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fbf28142..eda81c83 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -100,11 +100,14 @@ BUILT_SOURCES = \
quote_fmt_parse.c \
quote_fmt_parse.h \
sylpheed-marshal.c \
- sylpheed-marshal.h
+ sylpheed-marshal.h \
+ plugin-marshal.c \
+ plugin-marshal.h
lib_LTLIBRARIES = libsylpheed-plugin-0.la
libsylpheed_plugin_0_la_SOURCES = \
+ plugin-marshal.c plugin-marshal.h \
plugin.c
libsylpheed_plugin_0includedir=$(includedir)/sylpheed
@@ -127,6 +130,7 @@ libsylpheed_plugin_0_la_LIBADD = \
EXTRA_DIST = \
quote_fmt_parse.h \
sylpheed-marshal.list \
+ plugin-marshal.list \
version.h.in \
sylpheed.rc.in \
libsylpheed-plugin-0.def
@@ -172,3 +176,9 @@ sylpheed-marshal.h: sylpheed-marshal.list
sylpheed-marshal.c: sylpheed-marshal.list
$(GLIB_GENMARSHAL) $< --body --prefix=sylpheed_marshal > $@
+
+plugin-marshal.h: plugin-marshal.list
+ $(GLIB_GENMARSHAL) $< --header --prefix=syl_plugin_marshal > $@
+
+plugin-marshal.c: plugin-marshal.list
+ $(GLIB_GENMARSHAL) $< --body --prefix=syl_plugin_marshal > $@