aboutsummaryrefslogtreecommitdiff
path: root/plugin/attachment_tool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/attachment_tool/Makefile.am')
-rw-r--r--plugin/attachment_tool/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugin/attachment_tool/Makefile.am b/plugin/attachment_tool/Makefile.am
new file mode 100644
index 00000000..9fc7f39e
--- /dev/null
+++ b/plugin/attachment_tool/Makefile.am
@@ -0,0 +1,21 @@
+libdir = $(plugindir)
+
+lib_LTLIBRARIES = attachment_tool.la
+
+attachment_tool_la_SOURCES = attachment_tool.c
+attachment_tool_la_LDFLAGS = -module -no-undefined -avoid-version
+
+INCLUDES = \
+ $(GTK_CFLAGS) \
+ -I$(includedir) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/libsylph \
+ -I$(top_srcdir)/src
+
+test_la_LIBADD = \
+ $(GTK_LIBS) \
+ $(top_builddir)/src/libsylpheed-plugin-0.la \
+ $(top_builddir)/libsylph/libsylph-0.la
+
+install:
+install-plugin: install-am