aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2022-03-28 14:32:31 +0200
committerThomas White <taw@physics.org>2022-06-02 12:15:38 +0200
commit095fb15a3136fc20642d3ff12bfe26a1aec1b797 (patch)
treebb61d42159c876e379f07f37ae3f5b885188fd61 /CMakeLists.txt
parent6838dc35ffa07db47c48613aafb67441f1b620fa (diff)
Skeleton ASAP::O consumer
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6002d708..7702e643 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,13 @@ else ()
message(STATUS "ZMQ not found.")
endif ()
+pkg_search_module(ASAPO libasapo-consumer)
+if (ASAPO_FOUND)
+ message(STATUS "Found ASAP::O")
+else ()
+ message(STATUS "ASAP::O not found")
+endif ()
+
# Find out where forkpty() is declared
set(CMAKE_REQUIRED_LIBRARIES "-lutil")
check_symbol_exists(forkpty "pty.h" HAVE_FORKPTY_PTY_H)
@@ -108,6 +115,7 @@ set(HAVE_GDKPIXBUF ${GDKPIXBUF_FOUND})
set(HAVE_GDK ${GDK_FOUND})
set(HAVE_ZMQ ${ZMQ_FOUND})
set(HAVE_HDF5 1)
+set(HAVE_ASAPO ${ASAPO_FOUND})
set(PACKAGE_VERSION ${PROJECT_VERSION})
@@ -247,6 +255,10 @@ if ( ZMQ_FOUND )
list(APPEND INDEXAMAJIG_SOURCES src/im-zmq.c)
endif ()
+if ( ASAPO_FOUND )
+ list(APPEND INDEXAMAJIG_SOURCES src/im-asapo.c)
+endif ()
+
add_executable(indexamajig ${INDEXAMAJIG_SOURCES}
${CMAKE_CURRENT_BINARY_DIR}/version.c)
target_include_directories(indexamajig PRIVATE ${COMMON_INCLUDES})
@@ -258,6 +270,11 @@ if ( ZMQ_FOUND )
target_link_libraries(indexamajig ${ZMQ_LDFLAGS})
endif ()
+if ( ASAPO_FOUND )
+ target_include_directories(indexamajig PRIVATE ${ASAPO_INCLUDE_DIR})
+ target_link_libraries(indexamajig ${ASAPO_LDFLAGS})
+endif ()
+
# ----------------------------------------------------------------------
# get_hkl