aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2019-08-15 10:18:02 +0200
committerThomas White <taw@physics.org>2019-08-16 10:26:58 +0200
commit190bcee61bfd85df880d44e7dd69c2c898d0a27c (patch)
tree4bf794a4cc4679d09123b589c1fab6d5619b992f /CMakeLists.txt
parent0aa9e1af6d48b490906231192235f51232ed38f0 (diff)
Use LIBRARIES instead of LDFLAGS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43a61e4f..87513ea5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -245,7 +245,7 @@ if (CAIRO_FOUND)
add_executable(render_hkl ${RENDER_HKL_SOURCES})
target_include_directories(render_hkl PRIVATE ${COMMON_INCLUDES} ${CAIRO_INCLUDE_DIRS})
- target_link_libraries(render_hkl ${COMMON_LIBRARIES} ${CAIRO_LDFLAGS})
+ target_link_libraries(render_hkl ${COMMON_LIBRARIES} ${CAIRO_LIBRARIES})
list(APPEND CRYSTFEL_EXECUTABLES render_hkl)
@@ -349,17 +349,17 @@ list(APPEND CRYSTFEL_EXECUTABLES geoptimiser)
# If Cairo, gdk-pixbuf and GDK are all found, geoptimiser will add PNG support
if (CAIRO_FOUND)
target_include_directories(geoptimiser PRIVATE ${CAIRO_INCLUDE_DIRS})
- target_link_libraries(geoptimiser ${CAIRO_LDFLAGS})
+ target_link_libraries(geoptimiser ${CAIRO_LIBRARIES})
endif (CAIRO_FOUND)
if (GDKPIXBUF_FOUND)
target_include_directories(geoptimiser PRIVATE ${GDKPIXBUF_INCLUDE_DIRS})
- target_link_libraries(geoptimiser ${GDKPIXBUF_LDFLAGS})
+ target_link_libraries(geoptimiser ${GDKPIXBUF_LIBRARIES})
endif (GDKPIXBUF_FOUND)
if (GDK_FOUND)
target_include_directories(geoptimiser PRIVATE ${GDK_INCLUDE_DIRS})
- target_link_libraries(geoptimiser ${GDK_LDFLAGS})
+ target_link_libraries(geoptimiser ${GDK_LIBRARIES})
endif (GDK_FOUND)
if (TIFF_FOUND)