aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-06-21 12:06:47 +0200
committerThomas White <taw@physics.org>2018-06-21 12:06:47 +0200
commit3400d1416d8eb07b21595638c6d6e738bd6b1ccc (patch)
tree2d275b76cbfbdb36878ad3e63b790c64fdf9a5a7 /CMakeLists.txt
parent9564ff6039f73ef5840e1b545189fea50e3ab188 (diff)
Fix OpenCL tests and includes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfd1afa6..63ef99f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,6 +64,7 @@ check_include_file(fcntl.h HAVE_FCNTL_H)
check_include_file(stdlib.h HAVE_STDLIB_H)
check_include_file(unistd.h HAVE_UNISTD_H)
+# If we supposedly have OpenCL, check if the header is actually "CL/cl.h"
if (OpenCL_FOUND)
check_include_file(CL/cl.h HAVE_CL_CL_H "-I${OpenCL_INCLUDE_DIRS}")
endif (OpenCL_FOUND)