aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-04-30 12:09:31 +0200
committerThomas White <taw@physics.org>2020-07-29 18:42:57 +0200
commit6253b9603cf27e91a5f147943f6c32a35fd4d956 (patch)
tree9e4385073f1d32db87ad876547b994e3a9365c32 /CMakeLists.txt
parent1f00febd2ce3492e080afebf8d1c6368a19ae4e7 (diff)
Basic project persistence
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ddee846..5a4b51d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -385,7 +385,8 @@ list(APPEND CRYSTFEL_EXECUTABLES cell_tool)
if (GTK_FOUND)
set(CRYSTFEL_GUI_SOURCES src/crystfel_gui.c src/crystfelimageview.c
- src/gui_peaksearch.c src/gui_index.c src/gui_backend_local.c)
+ src/gui_peaksearch.c src/gui_index.c src/gui_backend_local.c
+ src/gui_project.c)
add_executable(crystfel ${CRYSTFEL_GUI_SOURCES})
target_include_directories(crystfel PRIVATE ${COMMON_INCLUDES} ${GTK_INCLUDE_DIRS})