aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-02-14 17:03:29 +0100
committerThomas White <taw@physics.org>2020-07-29 18:39:50 +0200
commit63eadd0582724e2626dddf0729ec991c1979b8cc (patch)
treed3623ff93591b9b0f066a79846820a5b697a7c6e /CMakeLists.txt
parentfc2d7dbbd535c2e2b2cb4b58b70f98ba5aa69a1e (diff)
Skeleton GUI and CrystFELImageView
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 985b3596..d8e9dd06 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -367,6 +367,21 @@ target_link_libraries(cell_tool ${COMMON_LIBRARIES})
list(APPEND CRYSTFEL_EXECUTABLES cell_tool)
# ----------------------------------------------------------------------
+# crystfel (main graphical user interface)
+
+if (GTK_FOUND)
+
+ set(CRYSTFEL_GUI_SOURCES src/crystfel_gui.c src/crystfelimageview.c)
+
+ add_executable(crystfel ${CRYSTFEL_GUI_SOURCES})
+ target_include_directories(crystfel PRIVATE ${COMMON_INCLUDES} ${GTK_INCLUDE_DIRS})
+ target_link_libraries(crystfel ${COMMON_LIBRARIES} ${GTK_LIBRARIES})
+
+ list(APPEND CRYSTFEL_EXECUTABLES crystfel)
+
+endif (GTK_FOUND)
+
+# ----------------------------------------------------------------------
# Install targets
set_target_properties(${CRYSTFEL_EXECUTABLES}