aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-03-16 10:56:56 +0100
committerThomas White <taw@physics.org>2020-07-29 18:42:24 +0200
commit6ec178c76a4298680f497b3a043ec1198d3a66b2 (patch)
tree36548dd9c6279e855df5fd56f3fa69e1663d19aa /CMakeLists.txt
parent952f89e192d848dfbc53e6d1e0da964dd82ffaf6 (diff)
Split off GUI peak search stuff to separate file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2311b565..124d8bf6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -371,7 +371,8 @@ list(APPEND CRYSTFEL_EXECUTABLES cell_tool)
if (GTK_FOUND)
- set(CRYSTFEL_GUI_SOURCES src/crystfel_gui.c src/crystfelimageview.c)
+ set(CRYSTFEL_GUI_SOURCES src/crystfel_gui.c src/crystfelimageview.c
+ src/gui_peaksearch.c)
add_executable(crystfel ${CRYSTFEL_GUI_SOURCES})
target_include_directories(crystfel PRIVATE ${COMMON_INCLUDES} ${GTK_INCLUDE_DIRS})