aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-09-25 15:51:16 +0200
committerThomas White <taw@physics.org>2019-03-11 16:49:36 +0100
commit85d6684288fd474f3eea89d6aa53c28b8fdafe91 (patch)
tree532ca99405bb2439bcc522803ee8e54dc52ea5c1 /CMakeLists.txt
parent166b4db3ba9a323553d4a25eae76725d59eb1141 (diff)
Initial cell_tool (implementing find_ambi only)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8888be0b..38b1723b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -360,6 +360,15 @@ target_link_libraries(make_pixelmap ${COMMON_LIBRARIES} ${HDF5_C_LIBRARIES})
list(APPEND CRYSTFEL_EXECUTABLES make_pixelmap)
# ----------------------------------------------------------------------
+# cell_tool
+
+set(CELL_TOOL_SOURCES src/cell_tool.c)
+add_executable(cell_tool ${CELL_TOOL_SOURCES})
+target_include_directories(cell_tool PRIVATE ${COMMON_INCLUDES})
+target_link_libraries(cell_tool ${COMMON_LIBRARIES})
+list(APPEND CRYSTFEL_EXECUTABLES cell_tool)
+
+# ----------------------------------------------------------------------
# Install targets
set_target_properties(${CRYSTFEL_EXECUTABLES}
@@ -391,6 +400,7 @@ install(FILES
doc/man/render_hkl.1
doc/man/whirligig.1
doc/man/make_pixelmap.1
+ doc/man/cell_tool.1
DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
)