aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-28 11:56:16 +0200
committerThomas White <taw@physics.org>2018-03-28 11:56:16 +0200
commita9f4c0ff4376267d90d6e8f9a0b6c012ec0588a4 (patch)
tree909a55ba30ea8549eaf49a4c4de78a743a093686 /CMakeLists.txt
parentbb55cca9f8d8f469b063bf46ba860557b3817873 (diff)
Build documentation by default
Unless gtk-doc isn't there
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7339fa86..6b8b9e5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,7 +103,7 @@ if (GTKDOC_FOUND)
docs/xml/gtkdocentities.ent)
configure_file(doc/reference/libcrystfel/CrystFEL-docs.sgml
docs/CrystFEL-docs.sgml COPYONLY)
- add_custom_target(documentation VERBATIM COMMAND
+ add_custom_target(documentation ALL VERBATIM COMMAND
${CMAKE_SOURCE_DIR}/doc/reference/libcrystfel/build-docs)
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/docs/html
DESTINATION ${CMAKE_INSTALL_DOCDIR})