aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-08-04 15:28:29 +0200
committerThomas White <taw@physics.org>2020-08-04 15:29:43 +0200
commitf9d454ae2a5c2c3ac2d7fc7161a1f02fc87da612 (patch)
tree4bb3005723c32f73d031efc1498c76b018daf084 /CMakeLists.txt
parentdce8a7b87023159480d06c963751da7e4fd2cb7c (diff)
Convert partial_sim to DataTemplate
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8ab5109..ced47030 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -180,13 +180,12 @@ install(DIRECTORY ${CMAKE_SOURCE_DIR}/scripts
# ----------------------------------------------------------------------
# partial_sim
-# FIXME: Restore!
-#set(PARTIAL_SIM_SOURCES src/partial_sim.c)
-#add_executable(partial_sim ${PARTIAL_SIM_SOURCES}
-# ${CMAKE_CURRENT_BINARY_DIR}/version.c)
-#target_include_directories(partial_sim PRIVATE ${COMMON_INCLUDES})
-#target_link_libraries(partial_sim ${COMMON_LIBRARIES})
-#list(APPEND CRYSTFEL_EXECUTABLES partial_sim)
+set(PARTIAL_SIM_SOURCES src/partial_sim.c)
+add_executable(partial_sim ${PARTIAL_SIM_SOURCES}
+ ${CMAKE_CURRENT_BINARY_DIR}/version.c)
+target_include_directories(partial_sim PRIVATE ${COMMON_INCLUDES})
+target_link_libraries(partial_sim ${COMMON_LIBRARIES})
+list(APPEND CRYSTFEL_EXECUTABLES partial_sim)
# ----------------------------------------------------------------------
# pattern_sim