aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2013-11-19 15:37:32 +0100
committerThomas White <taw@physics.org>2013-11-23 02:52:50 -0800
commit2e2386192d946988811cb75bac649877ba0fe0c7 (patch)
tree3ef93d64f2e2b04fa207df5f9ff68a2f0081d280 /Makefile.am
parent470773e8f7a1c46506cf24f281e6971101cfee1b (diff)
Break off integrate_rings_once()
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 69baeaee..270ddf21 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,7 +10,7 @@ noinst_PROGRAMS = tests/list_check tests/integration_check \
tests/pr_p_gradient_check tests/symmetry_check \
tests/centering_check tests/transformation_check \
tests/cell_check tests/pr_l_gradient_check \
- tests/pr_pl_gradient_check
+ tests/pr_pl_gradient_check tests/ring_check
MERGE_CHECKS = tests/first_merge_check tests/second_merge_check \
tests/third_merge_check tests/fourth_merge_check
@@ -25,7 +25,7 @@ PARTIAL_CHECKS = tests/partialator_merge_check_1 \
TESTS = tests/list_check $(MERGE_CHECKS) $(PARTIAL_CHECKS) \
tests/integration_check \
tests/symmetry_check tests/centering_check tests/transformation_check \
- tests/cell_check
+ tests/cell_check tests/ring_check
EXTRA_DIST += $(MERGE_CHECKS) $(PARTIAL_CHECKS)
@@ -103,6 +103,8 @@ tests_centering_check_SOURCES = tests/centering_check.c
tests_transformation_check_SOURCES = tests/transformation_check.c
+tests_ring_check_SOURCES = tests/ring_check.c
+
tests_cell_check_SOURCES = tests/cell_check.c
INCLUDES = -I$(top_srcdir)/libcrystfel/src -I$(top_srcdir)/data