aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2015-03-16 17:16:10 +0100
committerThomas White <taw@physics.org>2015-04-20 15:50:38 +0200
commit8a8e940575562086ab166e88a1f1927f420c564d (patch)
treea316c3c374136a7ab778eefbd6818ebb606f88dd /Makefile.am
parent4a7a658c2a4a05ba8be6bc0de698c5582817d3e3 (diff)
Add gradient test program and fix gradients
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 73d9a89e..b340dc86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,8 @@ noinst_PROGRAMS = tests/list_check tests/integration_check \
tests/pr_p_gradient_check tests/symmetry_check \
tests/centering_check tests/transformation_check \
tests/cell_check tests/ring_check \
- tests/prof2d_check tests/ambi_check
+ tests/prof2d_check tests/ambi_check \
+ tests/prediction_gradient_check
MERGE_CHECKS = tests/first_merge_check tests/second_merge_check \
tests/third_merge_check tests/fourth_merge_check
@@ -24,7 +25,8 @@ PARTIAL_CHECKS = tests/partialator_merge_check_1 \
TESTS = tests/list_check $(MERGE_CHECKS) $(PARTIAL_CHECKS) \
tests/integration_check \
tests/symmetry_check tests/centering_check tests/transformation_check \
- tests/cell_check tests/ring_check tests/prof2d_check tests/ambi_check
+ tests/cell_check tests/ring_check tests/prof2d_check tests/ambi_check \
+ tests/prediction_gradient_check
EXTRA_DIST += $(MERGE_CHECKS) $(PARTIAL_CHECKS)
EXTRA_DIST += relnotes-0.6.0
@@ -122,6 +124,8 @@ tests_ambi_check_SOURCES = tests/ambi_check.c
tests_pr_p_gradient_check_SOURCES = tests/pr_p_gradient_check.c \
src/post-refinement.c
+tests_prediction_gradient_check_SOURCES = tests/prediction_gradient_check.c
+
tests_centering_check_SOURCES = tests/centering_check.c
tests_transformation_check_SOURCES = tests/transformation_check.c