aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-03-07 16:58:58 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:18 +0100
commit91fcc695e253eb1085b55f0ff0978a9f0379cd8d (patch)
tree62636ba1bcb3d7d14cda36da4eb17fd9de43d735 /Makefile.am
parente1551f289d35e2d3a408ebb3ee905aea0e389fd2 (diff)
Avoid compiling any GPU code without OpenCL
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index aceeba44..a5de7acc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,7 @@ bin_PROGRAMS = src/pattern_sim src/process_hkl src/get_hkl src/indexamajig \
src/calibrate_detector src/partialator src/reintegrate \
src/estimate_background src/check_hkl src/sum_stack
-noinst_PROGRAMS = tests/list_check tests/gpu_sim_check
+noinst_PROGRAMS = tests/list_check
TESTS = tests/list_check
@@ -30,7 +30,15 @@ src_pattern_sim_SOURCES = src/pattern_sim.c src/diffraction.c src/utils.c \
src/symmetry.c src/thread-pool.c src/reflist.c
if HAVE_OPENCL
src_pattern_sim_SOURCES += src/diffraction-gpu.c src/cl-utils.c
+
TESTS += tests/gpu_sim_check
+noinst_PROGRAMS += tests/gpu_sim_check
+
+tests_gpu_sim_check_SOURCES = tests/gpu_sim_check.c src/utils.c \
+ src/diffraction.c src/diffraction-gpu.c \
+ src/thread-pool.c src/cell.c src/cl-utils.c \
+ src/symmetry.c src/detector.c src/hdf5-file.c \
+ src/image.c
endif
src_process_hkl_SOURCES = src/process_hkl.c src/sfac.c src/statistics.c \
@@ -110,12 +118,6 @@ src_estimate_background_SOURCES = src/estimate_background.c src/stream.c \
tests_list_check_SOURCES = tests/list_check.c src/reflist.c src/thread-pool.c \
src/utils.c
-tests_gpu_sim_check_SOURCES = tests/gpu_sim_check.c src/utils.c \
- src/diffraction.c src/diffraction-gpu.c \
- src/thread-pool.c src/cell.c src/cl-utils.c \
- src/symmetry.c src/detector.c src/hdf5-file.c \
- src/image.c
-
INCLUDES = "-I$(top_srcdir)/data"
EXTRA_DIST += src/cell.h src/hdf5-file.h src/image.h src/utils.h \