aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2017-12-05 12:14:25 +0100
committerThomas White <taw@physics.org>2018-02-27 17:12:42 +0100
commitb7fd93ba785778107214c2f137aaa128084be46b (patch)
treed4420d5b0846d0e1e98f6e081de34642690b78e7 /Makefile.am
parenteede09ad65f6f1d4169215ca55e3fff137217294 (diff)
Add test for linear scaling
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fe9c5cb3..b5708225 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,8 @@ noinst_PROGRAMS = tests/list_check tests/integration_check \
tests/centering_check tests/transformation_check \
tests/cell_check tests/ring_check \
tests/prof2d_check tests/ambi_check \
- tests/prediction_gradient_check
+ tests/prediction_gradient_check \
+ tests/linear_scale_check
MERGE_CHECKS = tests/first_merge_check tests/second_merge_check \
tests/third_merge_check tests/fourth_merge_check
@@ -25,7 +26,7 @@ TESTS = tests/list_check $(MERGE_CHECKS) $(PARTIAL_CHECKS) \
tests/integration_check \
tests/symmetry_check tests/centering_check tests/transformation_check \
tests/cell_check tests/ring_check tests/prof2d_check tests/ambi_check \
- tests/prediction_gradient_check
+ tests/prediction_gradient_check tests/linear_scale_check
EXTRA_DIST += $(MERGE_CHECKS) $(PARTIAL_CHECKS)
EXTRA_DIST += relnotes-0.6.3 announcement-0.6.3
@@ -122,6 +123,9 @@ tests_ring_check_SOURCES = tests/ring_check.c
tests_cell_check_SOURCES = tests/cell_check.c
+tests_linear_scale_check_SOURCES = tests/linear_scale_check.c src/scaling.c \
+ src/merge.c
+
INCLUDES = -I$(top_srcdir)/libcrystfel/src -I$(top_srcdir)/data
EXTRA_DIST += src/dw-hdfsee.h src/hdfsee.h src/render_hkl.h \