aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2014-04-15 14:44:34 +0200
committerThomas White <taw@physics.org>2014-04-15 14:44:34 +0200
commitf16a5d0ff7a64becd3a2462ef9ed18ade1f7b4d9 (patch)
treec2e8cd44386189791dd692c21babd7d3f28952f7 /Makefile.am
parent71d34176e3eff9c4630da1510fd55eeffcd794b7 (diff)
Link integration_check and prof2d_check with libcrystfel's list of libraries
... instead of the list of libraries used for the core programs. The former contains ncurses, but the latter doesn't. These tests #include a load of libcrystfel code, so they need the libcrystfel libraries.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 72a2eaab..a4efba1c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,6 +49,14 @@ AM_CPPFLAGS += -I$(top_srcdir)/lib
LDADD = $(top_builddir)/lib/libgnu.la @IGNORE_UNUSED_LIBRARIES_CFLAGS@
LDADD += $(top_builddir)/libcrystfel/libcrystfel.la @MAIN_LIBS@
+tests_integration_check_LDADD = $(top_builddir)/lib/libgnu.la
+tests_integration_check_LDADD += $(top_builddir)/libcrystfel/libcrystfel.la
+tests_integration_check_LDADD += @LIBCRYSTFEL_LIBS@
+
+tests_prof2d_check_LDADD = $(top_builddir)/lib/libgnu.la
+tests_prof2d_check_LDADD += $(top_builddir)/libcrystfel/libcrystfel.la
+tests_prof2d_check_LDADD += @LIBCRYSTFEL_LIBS@
+
src_partial_sim_SOURCES = src/partial_sim.c
src_pattern_sim_SOURCES = src/pattern_sim.c src/diffraction.c