aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2010-03-03 17:50:15 +0100
committerThomas White <taw@physics.org>2010-03-03 17:50:15 +0100
commit46a7ae42f1261a4aa0882af958ec93cc2e8d9610 (patch)
tree2976d88d9acce410575c32588be3bb1a8d4a91d7 /configure.ac
parent82792fbe72e2de4fa74f6bfc465159d86e59df43 (diff)
Stabilise DirAx stuff, and remove GLib dependency
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e8365f03..1911f67d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,18 +54,15 @@ AS_IF([test "x$enable_opencl" == "xyes"],
AC_ARG_ENABLE(gtk, AS_HELP_STRING([--disable-gtk], [Disable GTK+/GLib]))
-haveglib=false
havegtk=false
-AC_MSG_CHECKING([whether to use GTK/GLib])
+AC_MSG_CHECKING([whether to use GTK])
AS_IF([test "x$enable_gtk" != "xno"],
[
AC_MSG_RESULT([yes])
AM_PATH_GTK_2_0(2.0.0,
[
havegtk=true
- haveglib=true
- AC_DEFINE([HAVE_GLIB], [1], [Define to 1 if GLib is available])
- GTK_LIBS="$GTK_LIBS -lgthread-2.0 -lutil"
+ GTK_LIBS="$GTK_LIBS"
],
[
AC_MSG_WARN([GTK not found. hdfsee will not be built.])
@@ -76,10 +73,9 @@ AS_IF([test "x$enable_gtk" != "xno"],
])
AM_CONDITIONAL([HAVE_GTK], test x$havegtk = xtrue)
-AM_CONDITIONAL([HAVE_GLIB], test x$haveglib = xtrue)
AM_CONDITIONAL([HAVE_OPENCL], test x$have_opencl = xtrue)
CFLAGS="$CFLAGS $HDF5_CFLAGS $GTK_CFLAGS $GSL_CFLAGS $OPENCL_CFLAGS"
-LIBS="$LIBS $HDF5_LIBS -lm -lz $GSL_LIBS $GTK_LIBS $OPENCL_LIBS"
+LIBS="$LIBS $HDF5_LIBS -lm -lz $GSL_LIBS $GTK_LIBS $OPENCL_LIBS -lutil"
AC_OUTPUT(Makefile src/Makefile data/Makefile)