aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2011-02-12 12:26:07 -0800
committerThomas White <taw@physics.org>2012-02-22 15:27:14 +0100
commit62ed358058509abe847a0e9f1854b0e39d81ca6b (patch)
treed4bca21be7d4dfcb3214a12e7a8c20c095720c9c /configure.ac
parentd484070b401124dfde08801c8e56458a42335b70 (diff)
Restore --with-gsl in configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 32eba669..f7eac7e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,9 +30,14 @@ AC_ARG_WITH(hdf5,
[HDF5_LIBS="-lhdf5"])
-PKG_CHECK_MODULES([GSL], [gsl], [],
-[
- AC_ERROR([GSL is required])
+AC_ARG_WITH(gsl,
+[AS_HELP_STRING([--with-gsl], [specify location of GSL (instead of using pkg-config)])],
+[GSL_CFLAGS="-I$withval/include"
+ GSL_LIBS="-L$withval/lib -lgsl -lgslcblas -lm"],
+[PKG_CHECK_MODULES([GSL], [gsl], [],
+ [
+ AC_ERROR([GSL is required])
+ ])
])