aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2011-01-16 18:55:47 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:11 +0100
commitd1d03a3ed5869dac9060bb23dfc71cd8433c36ee (patch)
tree7dfdab8d4d0b30269e718ec95f18141af54f3e82 /configure.ac
parentebf81a687573e61c9f979f02809b6e98e10ad02a (diff)
Revert "Only use gl_IGNORE_UNUSED_LIBRARIES with recent GSL"
This reverts commit 5bac91a5eee6eab297e1cb8e8309654c8a22a530. It's not the GSL version that causes this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index df17b31c..da550a85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,14 +30,11 @@ AC_ARG_WITH(hdf5,
[HDF5_LIBS="-lhdf5"])
-PKG_CHECK_MODULES([GSL], [gsl], [],
-[
- AC_ERROR([GSL is required])
-])
-PKG_CHECK_MODULES([GSL_version], [gsl >= 1.13],
-[
- gl_IGNORE_UNUSED_LIBRARIES
-])
+AC_ARG_WITH(gsl,
+[AS_HELP_STRING([--with-gsl], [specify location of GSL])],
+[GSL_CFLAGS="-I$withval/include"
+ GSL_LIBS="-L$withval/lib -lgsl -lgslcblas"],
+[GSL_LIBS="-lgsl -lgslcblas"])
AC_ARG_ENABLE(opencl, AS_HELP_STRING([--enable-opencl], [Enable the use of OpenCL]))
@@ -156,6 +153,9 @@ PKG_CHECK_MODULES([GDK_pixbuf], [gdk-pixbuf], [],
])
+gl_IGNORE_UNUSED_LIBRARIES
+
+
CFLAGS="$CFLAGS $HDF5_CFLAGS $GSL_CFLAGS $OPENCL_CFLAGS -pthread $GTK_CFLAGS"
CFLAGS="$CFLAGS $LIBTIFF_CFLAGS -D_GNU_SOURCE $libPNG_CFLAGS $Cairo_CFLAGS"
CFLAGS="$CFLAGS $GDK_pixbuf_CFLAGS $GDK_pixbuf_2_CFLAGS"