aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2010-03-05 10:32:35 +0100
committerThomas White <taw@physics.org>2010-03-05 10:34:14 +0100
commitdaac7b3b2aae9895e6fd46588739b992655c66f5 (patch)
tree339201d6e98d631caa0edf166c6c3e42596228da /configure.ac
parentd8358c2158154ed14af37edb46b44f6c7b9feebb (diff)
forkpty() compatibility
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ce686568..f1e98934 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,11 +78,15 @@ AS_IF([test "x$enable_gtk" != "xno"],
AM_CONDITIONAL([HAVE_GTK], test x$havegtk = xtrue)
-AC_CHECK_FUNCS(forkpty,,
+AC_CHECK_FUNCS(forkpty,
+ AC_DEFINE([HAVE_FORKPTY_BSD], [1],
+ [Define to 1 if a Linux-style forkpty is available]),
AC_CHECK_LIB(util,forkpty,
- [AC_DEFINE(HAVE_FORKPTY) LIBS="$LIBS -lutil"],
- AC_CHECK_LIB(bsd,forkpty, [AC_DEFINE(HAVE_FORKPTY) LIBS="$LIBS -lbsd"])
- )
+ [
+ AC_DEFINE([HAVE_FORKPTY_LINUX], [1],
+ [Define to 1 if a Linux-style forkpty is available])
+ LIBS="$LIBS -lutil"
+ ])
)