aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2011-01-16 19:40:28 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:11 +0100
commitfa39e58d91ab5a2acee0d933b7a7565cbbc4bfe5 (patch)
treee453e7aa47fe5b7c8e416f9c904652e67a654d0e /configure.ac
parent6f2c69fde931686c7400595ae162bccdd899de51 (diff)
Add an option to fudge CBLAS if necessary
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9503acfa..32eba669 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,18 @@ PKG_CHECK_MODULES([GSL], [gsl], [],
])
+AC_ARG_ENABLE(gsl-fudge, AS_HELP_STRING([--enable-gsl-fudge],
+ [Use this option if you get lots of linker errors concerning GSL and CBLAS]))
+AC_MSG_CHECKING([whether to use the GSL CBLAS fudge])
+AS_IF([test "x$enable_gsl_fudge" == "xyes"],
+[
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([GSL_FUDGE], [1], [Define to 1 if the GSL fudge is needed])
+],
+[
+ AC_MSG_RESULT([no])
+])
+
AC_ARG_ENABLE(opencl, AS_HELP_STRING([--enable-opencl], [Enable the use of OpenCL]))
AC_MSG_CHECKING([whether to use OpenCL])
AS_IF([test "x$enable_opencl" == "xyes"],