aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-11-15 16:04:46 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:40 +0100
commit2c238039c2efda1788ea72c9fb41ff354acc8e97 (patch)
tree34c30c1a29e5bbbc50d25cb62aabe05cb196abb1 /libcrystfel/Makefile.am
parent3c896e8741763b66fa056d6c8d79557225e66ad2 (diff)
Move the "indexed reflection array" thing to where it can't do any harm
Diffstat (limited to 'libcrystfel/Makefile.am')
-rw-r--r--libcrystfel/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/libcrystfel/Makefile.am b/libcrystfel/Makefile.am
index 576044a6..141842ff 100644
--- a/libcrystfel/Makefile.am
+++ b/libcrystfel/Makefile.am
@@ -1,22 +1,22 @@
lib_LTLIBRARIES = libcrystfel.la
+
libcrystfel_la_SOURCES = src/reflist.c src/utils.c src/cell.c src/detector.c \
src/thread-pool.c src/image.c src/hdf5-file.c \
src/beam-parameters.c src/geometry.c src/statistics.c \
src/symmetry.c src/stream.c src/peaks.c \
- src/reflist-utils.c src/filters.c src/diffraction.c \
- src/diffraction-gpu.c src/cl-utils.c src/render.c \
- src/index.c src/dirax.c src/mosflm.c src/reax.c
+ src/reflist-utils.c src/filters.c src/cl-utils.c \
+ src/render.c src/index.c src/dirax.c src/mosflm.c \
+ src/reax.c
libcrystfel_la_includedir=$(includedir)/crystfel/
-libcrystfel_la_include_HEADERS = src/beam-parameters.h src/diffraction-gpu.h \
- src/hdf5-file.h src/reflist.h src/symmetry.h \
- src/cell.h src/diffraction.h src/image.h \
+
+libcrystfel_la_include_HEADERS = src/beam-parameters.h src/hdf5-file.h \
+ src/reflist.h src/symmetry.h src/cell.h \
src/reflist-utils.h src/thread-pool.h \
- src/cl-utils.h src/filters.h src/list_tmp.h \
+ src/cl-utils.h src/filters.h \
src/statistics.h src/utils.h src/detector.h \
src/geometry.h src/peaks.h src/stream.h \
- src/render.h src/index.h \
- ../data/defs.h
+ src/render.h src/index.h src/image.h
INCLUDES = "-I$(top_srcdir)/data"
AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib