aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-12-14 16:40:32 +0100
committerThomas White <taw@physics.org>2020-12-14 16:40:32 +0100
commit4f55621cac8ba66236fe602d625ac0a71b842150 (patch)
treec6dd18d7eda0c74cb8cd81d65ea9698102c65b2a /libcrystfel/meson.build
parent90adbfa497c6fa2623081edc69a4ac665f37d543 (diff)
Meson: Add GSL to libcrystfel's declare_dependency()
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index 51ed20bd..244fc4cc 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -126,7 +126,8 @@ libcrystfel = library('crystfel', [libcrystfel_sources, libcrystfel_versionc],
install : true)
libcrystfeldep = declare_dependency(include_directories : libcrystfel_includes,
- link_with : libcrystfel)
+ link_with : libcrystfel,
+ dependencies: gsldep)
install_headers(['src/reflist.h',