aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-10-13 15:17:42 +0200
committerThomas White <taw@physics.org>2021-10-13 15:19:04 +0200
commit8f4b2d8249fad3f8d05099b76de698a9f7db64a4 (patch)
tree63ae856fcfa9a46d97f22edd8ef621227129f619 /libcrystfel/meson.build
parent00831dc3cae2fd4df8ed13bdb8d2fa8bece7ceae (diff)
Remove NCurses dependency
It's only used once, to get background colours for 'indexamajig --int-diag', itself a rarely used feature. The dependency itself seems to cause problems for some people, particularly those not using system libraries for everything. So I think it's better just to remove it, and use ANSI escape codes directly.
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index 35893115..dc0fe2bf 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -12,11 +12,6 @@ if fftwdep.found()
conf_data.set10('HAVE_FFTW', 1)
endif
-ncursesdep = dependency('ncurses', required: false)
-if ncursesdep.found()
- conf_data.set10('HAVE_CURSES', 1)
-endif
-
xgandalfdep = dependency('xgandalf',
required: false,
fallback: ['xgandalf', 'xgandalf_dep'])
@@ -139,7 +134,7 @@ libcrystfel = library('crystfel', [libcrystfel_sources, libcrystfel_versionc],
include_directories: [libcrystfel_includes,
libcrystfel_conf_inc],
dependencies: [mdep, utildep, fftwdep, gsldep, zlibdep,
- hdf5dep, pthreaddep, ncursesdep,
+ hdf5dep, pthreaddep,
xgandalfdep, pinkindexerdep, fdipdep,
ccp4dep, msgpackdep],
install: true)