aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-08-29 16:22:21 +0200
committerThomas White <taw@physics.org>2023-08-29 16:22:21 +0200
commitb50c4f1609e0c030bf6574cf1fdc217e85ed3c33 (patch)
tree16b9565baf2d850a5da5e4cdb8f7747d7ba5c64f /libcrystfel/meson.build
parent65283ba88efca2a85e96fc1ac2128d3d999f8fa2 (diff)
Meson: Simplify Millepede build system
There are no dependencies, only a subproject via wrap.
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index 23b267c1..497abef6 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -38,10 +38,6 @@ else
cjsondep = dependency('', required : false)
endif
-millepededep = dependency('millepede',
- required: false,
- fallback: ['millepede', 'millepede_dep'])
-
xgandalfdep = dependency('xgandalf',
required: false,
fallback: ['xgandalf', 'xgandalf_dep'])
@@ -172,8 +168,7 @@ libcrystfel = library('crystfel', [libcrystfel_sources, libcrystfel_versionc],
dependencies: [mdep, utildep, fftwdep, gsldep, zlibdep,
hdf5dep, pthreaddep,
xgandalfdep, pinkindexerdep, fdipdep,
- ccp4dep, msgpackdep, seedeedep, cjsondep,
- millepededep],
+ ccp4dep, msgpackdep, seedeedep, cjsondep],
install: true)
libcrystfeldep = declare_dependency(include_directories: libcrystfel_includes,