aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2022-03-28 14:32:31 +0200
committerThomas White <taw@physics.org>2022-06-02 12:15:38 +0200
commit095fb15a3136fc20642d3ff12bfe26a1aec1b797 (patch)
treebb61d42159c876e379f07f37ae3f5b885188fd61 /meson.build
parent6838dc35ffa07db47c48613aafb67441f1b620fa (diff)
Skeleton ASAP::O consumer
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index be0f6477..964d3f61 100644
--- a/meson.build
+++ b/meson.build
@@ -69,6 +69,11 @@ if zmqdep.found()
conf_data.set10('HAVE_ZMQ', true)
endif
+asapodep = dependency('libasapo-consumer', required: false)
+if asapodep.found()
+ conf_data.set10('HAVE_ASAPO', 1)
+endif
+
if cc.has_function('clock_gettime', prefix: '#include <time.h>')
conf_data.set10('HAVE_CLOCK_GETTIME', true)
endif
@@ -167,8 +172,13 @@ if zmqdep.found()
indexamajig_sources += ['src/im-zmq.c']
endif
+if asapodep.found()
+ indexamajig_sources += ['src/im-asapo.c']
+endif
+
indexamajig = executable('indexamajig', indexamajig_sources,
- dependencies: [mdep, libcrystfeldep, gsldep, pthreaddep, zmqdep],
+ dependencies: [mdep, libcrystfeldep, gsldep,
+ pthreaddep, zmqdep, asapodep],
install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')