aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorValerio Mariani <valmar@slac.stanford.edu>2022-03-31 16:26:29 -0700
committerThomas White <taw@physics.org>2022-04-01 11:49:30 +0200
commit17163c01fa6864dd2ea48275cadfe3ada436a24b (patch)
treef4aae8b85f29ca3466f19bb775f92733fff0a72e /meson.build
parent385adbbd23969384a3ee2a6f17b1fd4c7e7442c3 (diff)
Make opencl optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 843b8e9d..fa369ef7 100644
--- a/meson.build
+++ b/meson.build
@@ -56,7 +56,7 @@ if cairodep.found()
conf_data.set10('HAVE_CAIRO', 1)
endif
-opencldep = dependency('OpenCL', required: false)
+opencldep = dependency('OpenCL', required: get_option('opencl'))
if opencldep.found()
conf_data.set10('HAVE_OPENCL', 1)
endif