aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-08-03 12:04:41 +0200
committerThomas White <taw@physics.org>2020-08-03 12:04:41 +0200
commit1fa93ed777dad73fbd7473f5a28bedda790a1100 (patch)
tree4bdba8e4d7253c443881ccb85f98285d0c5d7d9b /meson.build
parentf011c58c95953586bcf71203bde70fc963af1297 (diff)
meson: Request HDF5 1.10 API
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8132240a..3a36b11d 100644
--- a/meson.build
+++ b/meson.build
@@ -31,6 +31,9 @@ if not hdf5dep.found()
error('Couldn\'t find HDF5')
endif
+# Request HDF5 1.10-style API
+add_project_arguments('-DH5_USE_110_API', language : 'c')
+
# "Optional" dependencies
fftwdep = dependency('fftw3', required : false)
if fftwdep.found()