aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-12-19 11:30:48 +0100
committerThomas White <taw@physics.org>2023-12-19 11:37:27 +0100
commit2456f3bf75c7754f85e53895b465c4c44836805a (patch)
tree777752aa9a539579d37ea71bf8d1b1259bc25dc7 /meson.build
parent76b2c2c22b07a28dc04ecd65333bb02d0749b78b (diff)
Meson: Fix installation location for crystfel_geometry.5
Previously, this file ended up in man1, where it couldn't be found.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3830acb0..b30de9c4 100644
--- a/meson.build
+++ b/meson.build
@@ -281,7 +281,6 @@ subdir('tests')
pandoc = find_program('pandoc', required: false)
pandoc_pages = ['indexamajig.1.md',
- 'crystfel_geometry.5.md',
'adjust_detector.1.md',
'align_detector.1.md']
@@ -297,6 +296,14 @@ if pandoc.found()
endforeach
endif
+custom_target('crystfel_geometry.5.md',
+ input: 'doc/man/crystfel_geometry.5.md',
+ output: 'crystfel_geometry.5',
+ command: [pandoc, '@INPUT@','-o', '@OUTPUT@',
+ '-s', '-f', 'markdown-smart', '-t', 'man'],
+ install: true,
+ install_dir: join_paths(get_option('mandir'), 'man5'))
+
install_man(['doc/man/ambigator.1',
'doc/man/cell_explorer.1',
'doc/man/cell_tool.1',