aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-02-22 11:59:07 +0100
committerThomas White <taw@physics.org>2023-05-02 10:53:09 +0200
commit41ed47a931e4c162c9a501981b6f19cd725f6e43 (patch)
tree0d6999f68c7ccd3bbd37bad4c70ab94797e064c5 /meson.build
parent1995ba5ada88e3c1949eaf245c5e8e60dff5a3cc (diff)
Remove pattern_sim and partial_sim
Use of these programs has been following this pattern for several years: 1. Neglect 2. Once yearly attempt by someone to use either tool 3. Discovery that it's totally broken 4. Bug report and fast bug fix 5. Go to 1. For more discussion, see the issue referenced below. Closes: https://gitlab.desy.de/thomas.white/crystfel/-/issues/81
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build32
1 files changed, 0 insertions, 32 deletions
diff --git a/meson.build b/meson.build
index 21f4534a..65a65823 100644
--- a/meson.build
+++ b/meson.build
@@ -48,14 +48,6 @@ if cairodep.found()
conf_data.set10('HAVE_CAIRO', true)
endif
-opencldep = dependency('OpenCL', required: get_option('opencl'))
-if opencldep.found()
- conf_data.set10('HAVE_OPENCL', true)
- if cc.has_header('CL/cl.h', dependencies: opencldep)
- conf_data.set10('HAVE_CL_CL_H', true)
- endif
-endif
-
zmqdep = dependency('libzmq', required: false)
if zmqdep.found()
conf_data.set10('HAVE_ZMQ', true)
@@ -88,13 +80,6 @@ executable('cell_tool',
install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
-# partial_sim
-executable('partial_sim',
- ['src/partial_sim.c', versionc],
- dependencies: [mdep, libcrystfeldep, gsldep, pthreaddep],
- install: true,
- install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
-
# process_hkl
process_hkl = executable('process_hkl',
['src/process_hkl.c', versionc],
@@ -241,21 +226,6 @@ if gtkdep.found()
install_dir: get_option('datadir') / 'applications')
endif
-# pattern_sim
-if hdf5dep.found()
- pattern_sim_sources = ['src/pattern_sim.c', 'src/diffraction.c', versionc]
- if opencldep.found()
- pattern_sim_sources += ['src/diffraction-gpu.c', 'src/cl-utils.c']
- endif
- executable('pattern_sim', pattern_sim_sources,
- dependencies: [mdep, libcrystfeldep, gsldep, hdf5dep, opencldep],
- install: true,
- install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')
-endif
-# For testing (see tests/meson.build)
-simulation_bits = files(['src/diffraction.c',
- 'src/diffraction-gpu.c',
- 'src/cl-utils.c'])
# ************************ Misc resources ************************
@@ -289,8 +259,6 @@ install_man(['doc/man/ambigator.1',
'doc/man/list_events.1',
'doc/man/make_pixelmap.1',
'doc/man/partialator.1',
- 'doc/man/partial_sim.1',
- 'doc/man/pattern_sim.1',
'doc/man/process_hkl.1',
'doc/man/render_hkl.1',
'doc/man/whirligig.1'])