aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-02-12 12:40:50 +0100
committerThomas White <taw@physics.org>2021-02-12 17:27:44 +0100
commit5ceed23ffdae85bb42b4d2f01a7a02485dd8c954 (patch)
tree785c77b19e1f9746b044409591f6f00ff7021730 /meson.build
parenta9334fdf379923d737bf3be504c42a901f5b8009 (diff)
GUI: Add CCP4 libraries and hide MTZ export options if not found
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b7ba1c4b..21bfa2f6 100644
--- a/meson.build
+++ b/meson.build
@@ -94,6 +94,11 @@ if cc.has_function('clock_gettime', prefix : '#include <time.h>')
conf_data.set10('HAVE_CLOCK_GETTIME', 1)
endif
+ccp4dep = dependency('libccp4c', required: false)
+if ccp4dep.found()
+ conf_data.set10('HAVE_LIBCCP4', 1)
+endif
+
# ************************ libcrystfel (subdir) ************************
subdir('libcrystfel')
@@ -231,8 +236,10 @@ if gtkdep.found()
gui_sources += 'src/gui_backend_slurm.c'
endif
+
executable('crystfel', gui_sources,
- dependencies : [mdep, libcrystfeldep, gtkdep, gsldep, slurmdep],
+ dependencies : [mdep, libcrystfeldep, gtkdep, gsldep, slurmdep,
+ ccp4dep],
install : true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')