aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-04-12 17:10:24 +0200
committerThomas White <taw@physics.org>2023-06-01 15:31:50 +0200
commit6d11d4f13eb46d67f5a619dec93f4b6c4c0d9718 (patch)
treefb6300402b9b27ab86137aa1d88b357d26266102 /meson.build
parentde407aa9fa93192aad6773a53fe51295d9c8cb8e (diff)
Meson: Add ASAP::O producer dependency
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 11 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 8f6567fa..08247ba3 100644
--- a/meson.build
+++ b/meson.build
@@ -53,9 +53,16 @@ if zmqdep.found()
conf_data.set10('HAVE_ZMQ', true)
endif
-asapodep = dependency('libasapo-consumer', required: false)
-if asapodep.found()
- conf_data.set10('HAVE_ASAPO', true)
+# There are two separate dependencies for ASAP::O (consumer and producer)
+# We need both of them.
+asapoproddep = dependency('libasapo-producer', required: false)
+if asapoproddep.found()
+ asapodep = dependency('libasapo-consumer', required: true)
+ if asapodep.found()
+ conf_data.set10('HAVE_ASAPO', true)
+ endif
+else
+ asapodep = dependency('', required: false)
endif
if cc.has_function('clock_gettime', prefix: '#include <time.h>')
@@ -161,7 +168,7 @@ endif
indexamajig = executable('indexamajig', indexamajig_sources,
dependencies: [mdep, libcrystfeldep, gsldep,
- pthreaddep, zmqdep, asapodep],
+ pthreaddep, zmqdep, asapodep, asapoproddep],
install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')