aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2022-11-16 11:57:13 +0100
committerThomas White <taw@physics.org>2023-05-02 11:22:29 +0200
commit7260e3a2710296665dbceb427e447da38175513f (patch)
treec2d71c750755c597d217be2e269e386130a89909 /meson.build
parentd5289850ddee26f603b1fddbc652f6d609905927 (diff)
indexamajig: Add --cpu-pin
Similar code was stripped out 3.5 years ago by 4f4e5d05269eee6b192c271f2f9730a1ad3a4fbd. However, it seems there are still systems where it improves performance a lot.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 65a65823..8f6567fa 100644
--- a/meson.build
+++ b/meson.build
@@ -62,6 +62,12 @@ if cc.has_function('clock_gettime', prefix: '#include <time.h>')
conf_data.set10('HAVE_CLOCK_GETTIME', true)
endif
+if cc.has_function('sched_setaffinity',
+ prefix: '#include <sched.h>',
+ args: '-D_GNU_SOURCE')
+ conf_data.set10('HAVE_SCHED_SETAFFINITY', true)
+endif
+
# ************************ libcrystfel (subdir) ************************
subdir('libcrystfel')