aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-08-19 15:32:08 +0200
committerThomas White <taw@physics.org>2021-08-19 17:55:45 +0200
commit8478dff2562b4fc2ff62239c322f4ecf4b5d0e1e (patch)
tree73ccc8e0a6afccfa606560f4db430efd50c9ebe9 /meson.build
parentdf8fc79e9ed4ac07f02574459f89f8ed8a5f2986 (diff)
Meson: Check for SLURM headers as well as library
It seems that some systems have "-lslurm" but no <slurm/slurm.h>. Therefore, we need to check for both. Of course, ideally the outer test using pkg-config should work.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index acb33250..04c7cc2b 100644
--- a/meson.build
+++ b/meson.build
@@ -25,7 +25,9 @@ pthreaddep = dependency('threads', required: true)
# Try via pkg-config first:
slurmdep = dependency('slurm', required: false)
if not slurmdep.found()
- slurmdep = cc.find_library('slurm', required: false)
+ slurmdep = cc.find_library('slurm',
+ has_headers: 'slurm/slurm.h',
+ required: false)
endif
if slurmdep.found()