aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-08-27 17:00:10 +0200
committerThomas White <taw@physics.org>2020-08-27 17:00:10 +0200
commita68e04acd70ca4ec42f23190712249a2ad974fe6 (patch)
tree8c5a7b527c8e8be9bf51c34ee965eb1f0ec82d8c /meson.build
parent7c839f23409c88235132ff054c8a767be9895147 (diff)
Drop GTK2 and GDK2 altogether
Only the main GUI and cell_explorer use GTK, and the GUI is completely bound to GTK3.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index bef509ff..e1eb56d4 100644
--- a/meson.build
+++ b/meson.build
@@ -45,20 +45,12 @@ if fftwdep.found()
endif
gtkdep = dependency('gtk+-3.0', required : false)
-if not gtkdep.found()
- gtkdep = dependency('gtk+-2.0', required : false)
-else
- add_project_arguments('-Wno-deprecated-declarations', language : 'c')
-endif
-
if gtkdep.found()
+ add_project_arguments('-Wno-deprecated-declarations', language : 'c')
conf_data.set10('HAVE_GTK', 1)
endif
gdkdep = dependency('gdk-3.0', required : false)
-if not gdkdep.found()
- gdkdep = dependency('gdk-2.0', required : false)
-endif
if gdkdep.found()
conf_data.set10('HAVE_GDK', 1)
endif