aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-04-16 10:47:50 +0200
committerThomas White <taw@physics.org>2021-04-16 10:47:50 +0200
commitab07fd8a99b3199bf4aff52b32432e4fd24f7b3a (patch)
tree1e62089bb7d168ca1e2041a5f535d1a7caae7fc5 /meson.build
parentafcb7b568947c20fb3477a178be5aefe3203b603 (diff)
Meson: Update and fix MsgPack/ZMQ dependencies
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 2 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 12b601c0..680edf05 100644
--- a/meson.build
+++ b/meson.build
@@ -85,11 +85,6 @@ if zmqdep.found()
conf_data.set10('HAVE_ZMQ', 1)
endif
-msgpackdep = dependency('msgpack', required : false)
-if msgpackdep.found()
- conf_data.set10('HAVE_MSGPACK', 1)
-endif
-
if cc.has_function('clock_gettime', prefix : '#include <time.h>')
conf_data.set10('HAVE_CLOCK_GETTIME', 1)
endif
@@ -184,13 +179,12 @@ executable('whirligig',
indexamajig_sources = ['src/indexamajig.c', 'src/im-sandbox.c',
'src/process_image.c', 'src/time-accounts.c',
versionc]
-if zmqdep.found() and msgpackdep.found()
+if zmqdep.found()
indexamajig_sources += ['src/im-zmq.c']
endif
executable('indexamajig', indexamajig_sources,
- dependencies : [mdep, libcrystfeldep, gsldep, pthreaddep, zmqdep,
- msgpackdep],
+ dependencies : [mdep, libcrystfeldep, gsldep, pthreaddep, zmqdep],
install : true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')